Probleme beim erstellen einer neuen Variable

Fragen zu Stata Syntax und Do-Files.

Probleme beim erstellen einer neuen Variable

Beitragvon A.K.K. » Di 29. Okt 2019, 20:55

Hallo Zusammen,

ich habe leider einige Probleme bei meiner Stata-Rechnung.
Ich möchte eine neue Variable generieren, deren Inhalt sich aus 3 bereits bestehenden (auch Variablen, die ich erstellt habe) errechnet werden soll.

Ich habe einen Index für 3 Parteien erstellt, der von 0-3 geht.
Ich möchte eine Endvariable generieren, die alle 3 Variablen enthält.

Meine codierung sieht wir folgt aus:
gen X1=.
replace X1= 3 if k1 == 3 | k2 == 3 | k3 == 3
replace X1 = 2 if k1 == 2 | k2 == 2 | k3 == 2
replace X1 = 1 if k1 == 1 | k2 == 1 | k3 == 1
replace X1 = 0 if k1 == 0 | k2 == 0 | k3 == 0

Wenn ich anschließend meine X1 Variable mit dem fre Befehl überprüfen möchte erhalte ich als Ergebnis immer nur : Valid 0. 3/2/1 werden mir nicht angezeigt und alle Fälle fallen unter 0.

Hat jemand eine Idee woran es liegen könnte oder kann mir hier eine andere Variante zeigen?

Vielen Dank und schönen Abend,
A.K.K. :)
A.K.K.
 
Beiträge: 1
Registriert: Di 29. Okt 2019, 20:46
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: Probleme beim erstellen einer neuen Variable

Beitragvon Staxa » Do 31. Okt 2019, 10:55

Also dir sollte klar sein, dass hier die Reihenfolge, in der du die Befehle ausführt eine Rolle spielt. So wie ich das verstehe haben hier alle 0, weil jeder Fall mindestens eine 0 hat auf der Variable. Hier würde ich über Kreutabellen und mit dem list Befehl vorgehen und einige Fälle man inspizieren.
Stata für Anfänger: www.statabook.com
Staxa
 
Beiträge: 154
Registriert: Di 27. Feb 2018, 12:56
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post


Zurück zu Stata Syntax

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron